[ IntelliJ IDEA ] Grails (グレイルズ) と、 Java のバージョンを変える

最初に

新しい、Grails と、 Java が入っており GRAILS_HOME と、JAVA_HOME の環境変数を変更していることを確認。

Java のバージョンを変える

手順

  1. File -> Project Structure -> Project
  2. New.. を選択
  3. JDKのインストールフォルダを選択
  4. 選択ボックスから使うJDKを選択

File -> Project Structure から、一番左のペインの Projectを選択すると Project SDK: に現在のJDKが選択されている。

ここにある New.. から JDK を選択してインストールしたフォルダを選択。
これで選択ボックスに新しいJDKが増えているので、使いたいJDKを選択すればよい。

Grails のバージョンを変える 方法1

手順

  1. プロジェクトを右クリック -> Add Framework Support -> Groovy -> Create
  2. 新しいGrils を選択

プロジェクトを右クリックして、Add Framework Support を選択
Groovyをクリックしてすると、チェックボックスをオンにすると、 Create と、 Configure ボタンがアクティブになる。
Createボタンを押して、新しく入れた Grails を選択。
最後に、Configureを押して、jar が沢山入っていることを確認。

Grails のバージョンを変える 方法2

上記の方法よりさらに簡単な方法
手順

  1. プロジェクトを右クリック -> Grails -> Change SDK version
  2. 新しいGrails を選択
  3. プロジェクトを右クリックして、Grails から、 Change SDK version を選択
    ここで、create をクリック。
    後は上の Grails のバージョンを変える 方法1 と同じ
    Createボタンを押して、新しく入れた Grails を選択。
    最後に、Configureを押して、jar が沢山入っていることを確認。







コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください